Problem with deploy_id parameter in post script when using LXD as VM driver

Hello everybody,

As you probably know we are working in a new addon to manage LXD containers with OpenNebula. In order to use the 8021Q driver with this containers we do all what we need but OpenNebula doesn’t execute post driver with the proper deploy_id parameter. It receives (as a second argument) a single line “-” instead of the deploy_id (ex. one-46).

Have anyone experienced this issue? Where does this parameter come from?

With KVM works OK.


Found it! Forgot to send “Deploy_id” as a response from deploy script.