Question about "wild" VMs support in ONE 4.14

Hi all

We are testing the new OpenNebula 4.14 beta1 and the new features. My question is about the “wild” VMs import, this is a very nice feature that we want to try, is this feature already included in the current beta? if so how can I test it? it’s already documented?

Thanks in advance!

+1 for these information


Thanks for testing the 4.14 beta1, your feedback is very much appreciated!

Regarding the wild VMs, it is indeed present in the beta1 and it is available for all supported hypervisors, including the hybrid ones. You can find documentation on importing WILD VMs here:



Thanks a lot for the info!

Hi @tinova, @alvaro_simongarcia

@alvaro_simongarcia , Is this feature working for you?

We tried it this morning but we did not manage to get it working. We put by hand a VM running on an OpenNebula host so the VM is running on the KVM host but not through OpenNebula but when we go the Sunstone UI, we get the following errors and we are not able any more to see/edit/monitor the configuration for this host on the Sunstone UI:

DataTables warning: table id=datatable_host_wilds - Requested unknown parameter '1' for row 0. For more i

information about this error, please see

Then, If we try it through the command line, we see the wild VM:

We see the wild VM there but not in the same way that mentioned on the documentation,

We tried to import it but it did not work:

[root@test-opennebula4 ~]# onehost importvm 3 wild_VM
No importable wilds with name 'wild_VM' found.

[root@test-opennebula4 ~]# onehost importvm 1 wild_VM 
No importable wilds with name 'wild_VM' found.

Maybe, I am not understanding this correctly so @tinova, I would appreciate if you can have a look/help me on it :smile:

@alvaro_simongarcia, I am curious about your report and if you managed to get it working :slight_smile:

Thanks in advance,

Hi @esfreire

In our case is working correctly, the wild VM was started as root user in our hyp and then it was imported from the command line:

onehost importvm 29 node2204_wild_VM

And it was included and monitored without problems.
btw our hyps were updated before that:

onehost sync --force


Hi @alvaro_simongarcia

Thank you very much for your confirmation :smile:

In my previous test, I started the VM with owner/group oneadmin and under the datastores PATH, which it did not work.

Now, we have started it as owner/group root and under the /opt PATH and started it by hand with the virsh create command. Then, we have imported it from the Sunstone UI and now we can see it running on OpenNebula and we can access to it through VNC :slight_smile:

One thing about this, although I see this VM running in the Sunstone Ui/onevm list command and with the ID 78 but if I go to the host where it is running, I don’t see anything created on the datastores PATH with this ID (as it is for the VMs started from OpenNebula) and I see the VM running on the host with the same name that it was deployed at the beginning. Is this the expected behaviour? @alvaro_simongarcia, does it happen the same for you? or maybe, Am I still doing something wrong?

Thanks and sorry for the noise,

Hi @esfreire

As far as I know the import command only includes the “wild” VM into your db to be monitorized. It does not migrate any new images or vnet aliases. You can check the VM status from sunstone and the client and you can shutdown or reboot the VM at any time (but you cannot execute a VM migration or live migration).


Hi @alvaro_simongarcia

Thank you very much for your answer :smile:

I also understood that but I preferred to confirm it :slight_smile: