Release of WordPress 5.0 appliance


we want to share with you news about the newly available appliance in the OpenNebula Marketplace with preinstalled WordPress 5.0 service. You can try the appliance by following short instructions below. We would be happy if you give us any feedback about this appliance, about the idea of having appliances with some other services in the OpenNebula Marketplace to quickly start with, or any ideas for improvements. Do you have tips for other cool services? We would love to hear it!!!

Please, let us know. Thank you!

Here follows a quick picture guide on how to get and run the WordPress in your own OpenNebula.

WARNING: It is crucial to setup networking correctly - by default the service will listen on the first address of the interface with the default route. Otherwise, set the contextualization variable ONEAPP_SITE_HOSTNAME to the right hostname or IP address.

In the sunstone download the image from the marketplace as seen here:

During the instantiation you can bootstrap Wordpress with some preset (in this case I am using plain HTTP so no SSL):

On the first boot up the VM will configure and bootstrap itself with provided values:

Hello, I have just installed this and it bootsraps fine whcih is good.

One issue I am having is when I upload a theme it says the link has expired but it hasn’t, quick google suggests its the upload size , tried changing this in the php.ini file confirmed with phpinfo(); and still the same (After a reboot also), anyone else had thsi issue if so how do you fix it.

*** Sorted it ***

Turns out its the POST_MAX_SIZE in the /etc/php.ini

Tail -f /var/log/httpd/wordpress-error.log

[Mon Aug 26 23:45:28.945725 2019] [:error] [pid 3818] [client MY IP:56476] PHP Warning: POST Content-Length of 20878163 bytes exceeds the limit of 8388608 bytes in Unknown on line 0, referer: http://MYOTHERIP/wp-admin/theme-install.php?browse=featured

post_max_size = 8M

^^^ Change to something reasonable, maybe worth adding to the bootsrap process and for max_upload_size;