Shared datastore does not support transfer mode shared

I’m trying to add a new shared datastore and no matter what combination of settings i choose for the datastore i am unable to spin up a vm in that datastore. I always get the message “Image Datastore does not support transfer mode: shared”.


I’ve verified the permissions match on the folders and it is owned by the oneadmin user. i am able to ssh between hosts as oneadmin without password and create files in teh folder. permissions match between a working folder and the folder that doesnt work. I’ve also tried qcow2 mode with this result “Image Datastore does not support transfer mode: qcow2”, as well as creating a new cluster with the new datastore(s) and i still get the same results. I’ve tried restarting all teh opennebula services but still the issue persists. Any pointers would be appreciated or a copy of a working shared image datastore / system datastore.

Also tried making a non-shared ssh datastore and am able to create VMs on the gluster / fuse mounted file but i am unable to migrate the VM live or otherwise. live fails saying the datastore isnt shared as expected, live fails saying “DEPLOY: Could not create domain from /raid/images/168/256/deployment.2”

tried using the legacy built in glusterfs datastore as well but still get the same message that
“Image Datastore does not support transfer mode: shared” no combination of things so far, has worked. anytime the shared option shows up in the image datastore it will throw that error.

I’ve also tried setting base path but that is ignored as well as tinkering around with the shared TM_MAD_CONF in oned.conf but all to no avail. Also tried disabling all other datastores but the issue persists.

disabling apparmor made no difference, nor did trying just normal files instead of the fuse mounted gluster shares.

This seems to be a misconfigured oned.conf, missing/wrong TM_MAD_CONF entries. Did you change something there? or are you using any TM_MAD_SYSTEM in the VM template?

Really appreciate the response, i’m totally out of ideas on this. Below is the oned.conf tm_mad_conf section as well as the vm template, and storage settings. let me know if theres anything else i can provide that would be helpful

TM_MAD_CONF = [
NAME = “dummy”, LN_TARGET = “NONE”, CLONE_TARGET = “SYSTEM”, SHARED = “YES”,
DS_MIGRATE = “YES”
]

TM_MAD_CONF = [
NAME = “lvm”, LN_TARGET = “NONE”, CLONE_TARGET = “SELF”, SHARED = “YES”,
DRIVER = “raw”
]

TM_MAD_CONF = [
NAME = “shared”, LN_TARGET = “NONE”, CLONE_TARGET = “SYSTEM”, SHARED = “YES”,
DS_MIGRATE = “YES”, TM_MAD_SYSTEM = “ssh”, LN_TARGET_SSH = “SYSTEM”,
CLONE_TARGET_SSH = “SYSTEM”, DISK_TYPE_SSH = “FILE”
]

TM_MAD_CONF = [
NAME = “fs_lvm”, LN_TARGET = “SYSTEM”, CLONE_TARGET = “SYSTEM”, SHARED=“YES”,
DRIVER = “raw”
]

TM_MAD_CONF = [
NAME = “qcow2”, LN_TARGET = “NONE”, CLONE_TARGET = “SYSTEM”, SHARED = “YES”,
DS_MIGRATE = “YES”, TM_MAD_SYSTEM = “ssh”, LN_TARGET_SSH = “SYSTEM”,
CLONE_TARGET_SSH = “SYSTEM”, DISK_TYPE_SSH = “FILE”, DRIVER = “qcow2”
]

TM_MAD_CONF = [
NAME = “ssh”, LN_TARGET = “SYSTEM”, CLONE_TARGET = “SYSTEM”, SHARED = “NO”,
DS_MIGRATE = “YES”, ALLOW_ORPHANS=“YES”
]

TM_MAD_CONF = [
NAME = “ceph”, LN_TARGET = “NONE”, CLONE_TARGET = “SELF”, SHARED = “YES”,
DS_MIGRATE = “NO”, DRIVER = “raw”, ALLOW_ORPHANS=“mixed”,
TM_MAD_SYSTEM = “ssh,shared”, LN_TARGET_SSH = “SYSTEM”, CLONE_TARGET_SSH = “SYSTEM”,
DISK_TYPE_SSH = “FILE”, LN_TARGET_SHARED = “NONE”,
CLONE_TARGET_SHARED = “SELF”, DISK_TYPE_SHARED = “RBD”
]

TM_MAD_CONF = [
NAME = “iscsi_libvirt”, LN_TARGET = “NONE”, CLONE_TARGET = “SELF”, SHARED = “YES”,
DS_MIGRATE = “NO”, DRIVER = “raw”
]

TM_MAD_CONF = [
NAME = “dev”, LN_TARGET = “NONE”, CLONE_TARGET = “NONE”, SHARED = “YES”,
TM_MAD_SYSTEM = “ssh,shared”,
LN_TARGET_SSH = “SYSTEM”, LN_TARGET_SHARED = “NONE”,
DISK_TYPE_SSH = “FILE”, DISK_TYPE_SHARED = “FILE”,
CLONE_TARGET_SSH = “SYSTEM”, CLONE_TARGET_SHARED = “SELF”,
DRIVER = “raw”
]

TM_MAD_CONF = [
NAME = “vcenter”, LN_TARGET = “NONE”, CLONE_TARGET = “SYSTEM”, SHARED = “YES”
]

TM_MAD_CONF = [
NAME = “zfs”, LN_TARGET = “NONE”, CLONE_TARGET = “SELF”, SHARED = “yes”
]

and vm template i’m testing with:
CONTEXT = [
NETWORK = “YES”,
PASSWORD = “supersecurepassword”,
SSH_PUBLIC_KEY = “keys”,
USERNAME = “test” ]
CPU = “1”
CPU_MODEL = [
MODEL = “kvm64” ]
DISK = [
IMAGE_ID = “0” ]
HOT_RESIZE = [
CPU_HOT_ADD_ENABLED = “NO”,
MEMORY_HOT_ADD_ENABLED = “NO” ]
HYPERVISOR = “kvm”
INFO = “Please do not use this VM Template for vCenter VMs. Refer to the documentation https://bit.ly/37NcJ0Y
INPUTS_ORDER = “”
LOGO = “images/logos/ubuntu.png”
LXD_SECURITY_PRIVILEGED = “true”
MEMORY = “2048”
MEMORY_UNIT_COST = “MB”
NIC = [
NETWORK = “br0”,
NETWORK_UNAME = “oneadmin”,
SECURITY_GROUPS = “0” ]
OS = [
ARCH = “x86_64”,
BOOT = “” ]
SCHED_REQUIREMENTS = “HYPERVISOR!=“vcenter””
VCPU = “4”
here is the datastore config i’m trying to use: