Sinatra doesn't know this ditty trying to access OneFlow

I trying to access OneFlow with REST client
when I run this in same server that all open nebula services are existed
curl -u “oneadmin:pass”
I get this error

body { text-align:center;font-family:helvetica,arial;font-size:22px; color:#888;margin:20px} #c {margin:0 auto;width:500px;text-align:left}

Sinatra doesn’t know this ditty.

Try this:
get '/' do
  "Hello World"
what am I doing wrong?

Hello @AliQB,

Welcome to the forum. Please check if this post helps you:

Or you probably want to take a look on this Issue:

It should be fixed by 6.8, and even on 6.6, so can you please confirm which OpenNebula version are you using?

Thank you so much for your feedback
I am using version 6.4

We strongly suggest to use our latest version.
Are you able to use 6.8 CE?, or at least 6.4.5 LTS?

Also, you haven’t mentioned if you tried anything from the links I’ve shared. Please confirm.


The problem is that you are trying to issue a GET request to the route / which is an invalid path on the oneflow API. Try curl -u “oneadmin:pass” instead, it should give you a response with the pool of existing services.

I am given a preinstalled openNebula to connect another webapp to its REST apis I have to ask manager to update, I taught the problem is about a misconfiguration, If its about version I will try to update and check
I read links you mentioned, I didn’t find related solution

thank you for your feedback but I get same error