[SOLVED] Ceph Datestore Size not shown in Opennebula Webinterface


we have an opennebubla-cluster (not for productive use) with 2 nodes and 1 frontend. As Storage we use a ceph-cluster with 2 node (not for productive use).

Both cluster work well.

Now we tried to add a rbd pool to the opennebula, as discribed in the manual, but no capacity is shown in Opennebula Webinterface. It is not possible to publish anything on this datastore.

But if we try to get access from shell to the pool with the oneadmin user erverthing works well.

Thanks for help.

Hello @Schlapper

Can you see the size in the associated IMAGE datastore? Also, can you see the size in the SYSTEM datastore using the command onedatastore show?

Thx for your answer.

No It shows me Zero MB.

By the way i did this steps


when i mount my ceph on an other System it works well.

There was a bug related with ceph monitor, it’s already fixed, please check it and let me know if it applies to you.

1 Like

by the way I find the following information in the log:

Command execution failed (exit code: 255) /var/lib/one/remotes/tm/ceph/monitor with an hash follewed .

I i try to get acces on the shell on any Opennebula node by
rbd --id libvirt ls -l -p one

it works well.

Thank for your tip i gonna check the bug information.

dam I got it ! It was my fault! I used the hostname in BridgeList and CephHost but nameresulution doesnt work xDD. With the IP’s everything works well.

Thanks for helping.

Nice to hear that it’s working!