Sunstone/Fireedge can't handle pt-br keyboard


I’m trying to config a linux machine to use my pt-br keyboard, however with no success. I’m using the new Sunstone/FireEdge version. The VM Template and the VM itself are configured do use “pt-br” keybord map. Also tryed to set br-abnt2 keyboard in my Oracle Linux 8.

Pleass, help!

My VM is as follows:


Thanks for the detailed feedback. We’ll try to reproduce your behaviour and get back to you.

Hi @marcusrocha,

The VM in OpenNebula needs to have the correct keyboard layout for Guacamole VNC to work correctly. First, you will need to set the KEYMAP to an available option, in your case, pt-br. After that, an internal configuration is needed; you must connect to the VM and change the keyboard layout to match the selected keymap.


Hi @fborges ,

thanks for your answer. However, this is exactly what I did before posting.

A more detailed description of the situation follows:

  • My VM is confugired to the required keymap:


  • Also my VM is configured with the proper keymap, which is br-abnt2. Sorry, I do not know if it is possible to include an image here on order to show keymap configuration in Oracle Linux 8 or Windows 10 configuration showing that VM keymap is ok. Anyway, the command set keymaps in Oracle Linux 8 would be “localectl set-keymap br-abnt2”. Moreover, “localectl” alone will show locale and keymap sets.

  • This said, characters such as “âêãÓú” and so on will not be correctly displayed I use a VNC connection. Other misplaced characters are correctly placed after this configuration;

  • However, both tigerVNC and virt-viewer can connect to the KVM host and properly use the keymap pt-abnt2 (again, I’m sorry I cannot show inages here). Also tryed to copy br-abnt2 to pt-br with no results.

Finally, after posting, I decided to peruse guacamole’s docs and forum. There I found that guaca cannot cirrectly use non-us keymaps. It would require a different lib to process VNC, which conflicts with gacamoles´s design goals, as stated in the posts bellow:

Marcus Rocha

Hi again,

Can you please confirm that it is working with the Apache Guacamole web interface, without using OpenNebula?


Hi @fborges ,

no, it does not work with the Apache Guacmole web interface without using Guacamole.
Thus, after a bit testing, I came to believe it is not an OpenNebula issue. This why I used the term ’ “fix” '.
Anyway, it would limit the access to remote machine where the access through KVM’s VNC server would be required.



As it is on the Apache Guacamole website, “Guacamole is actually independent of keyboard layout, and will send the true local identity of the key pressed. The behavior of each key within the remote desktop should identically match the local behavior of that key”.

We have been trying with a Non-US keyboard, and it works for us. We see only one difference: our layout is the same in our keyboard, the VNC graphics section, and the one set on the VM.

From what we have been reading, we can see in yours the following configurations:

  • We assume your keyboard is pt-br, the same as your keymap.
  • Keymap set to pt-br.
  • The VM keymap is set to br-abnt2

Can you try to set the same language in all three?



Sorry for the delay, I took some time to perform a more thorough testing with Oracle Linux 8, Ubuntu 20.04.4 and AlmaLinux 8.6. Results are the same to all of these distros.

There’s a catch with our keyboards: most distros reffer to our current keyboards really as br-abnt2, nevertheless language setting is usually pt-br. So, what I had to do is to copy br-abnt2 keymap to a previously inexistent pt-br keymap.


  1. If VM is not set to pt-br, many special characters as misplaced.
  2. 2.1) If VM is set to pt-br and VM keymap is ok, all of the characters are placed in the expected locations.
    2.2) Problems arise when it comes to diacritics marks ` ´ ^ ~ which do not work. So, characters such as “ãÃâÂéÉèÈ” and so on cannot be typed,

Best regards


We cannot reproduce this issue.
We recommend you ask Apache Guacamole to receive a solution.



Thanks for your effort.

Marcus Rocha


Did you solve your problem? I’m getting the same issue with Spanish keyboard.


Hi, @Daniel_Ruiz_Molina !

Too bad, I was not able to solve the problem. I managed to fix the keyboard layout but could not have the dead keys (accents) working properly.

To solve this problem, the best solution I could find is to start a direct SSH connection to Linux VMs or a direct RDP connection to Windows VMs, thus avoiding to use OpenNebula’s Guacamole connections.


Hi, @marcusrocha

for my OpenNebula environment, it’s “impossible” to allow incoming connections to all my VMs, because normally, my OpenNebula is executing more than 500 VMs, all of them with private IP (and some could do NAT form inside to outside), but they haven’t got public IP, si I would have to configure a SNAT for each connection to redirect incoming connection to each private IP VM… isn’t it? mmmmm



Hi, @Daniel_Ruiz_Molina

Sure, for this number of hosts manual configuration would not be reasonable. Maybe you could use OpenVPN to stablish a VPN between your private network and your VMs (which should be assigned to some range of your private network). Actually, we are testing this setup. It seams to work fine, but we do not know yet the impact of the overhead imposed by the VPN.
Thus, you would be able to access your VMs directly.

On the bright side you will be able to use this VPN no matter which cloud provider you use.