Templates grayed out in sunstone for non-privileged users

We have a recently-deployed opennebula 4.8 installation with Sunstone enabled.
It appears that most non-privileged users, when they log into sunstone, see
the “cloud view” by default as described in the docs.
They have a tab called “VM” and the option to hit the + button to create another one.
This brings up a screen of all the public templates in the cluster but it appears
that they are all grayed out and you can’t actually select any of them.

Is there anything that can be done to allow normal users to create
VM’s on sunstone using the stock templates?
Previously we had only checked the admin view and that works fine.

Steve Timm

Turns out all you have to do is to either change the default view of the "users"
group in sunstone to be the “user” view or to make the same change in /etc/one/sunstone-views.yaml.
My non-privileged users can now launch vm’s.

Hi Steven,

If they appear in the grid list, they should be selectable, there is no functionality to disable/gray them out. If you cannot select them, probably it’s a bug, but lot of thins have been solved since one-4.8


Daniel–can you please clarify…
Are non-privileged users supposed to be able to launch virtual machines
from the “cloud” view of sunstone? I worked around this for the moment
by enabling my users to have the “users” view of sunstone and then they
could launch virtual machines. Is there any permissions thing that I
could be missing? Since there are still a few fermi-specific patches that
we have to make that have not made it into the main ONE4 yet I would
prefer not to have to upgrade.


If a user can instantiate a template through the users view, she can also do it through the cloud view, since the permissions are the same for the template resource. (group+use/other+use)