vCenter :: Virtual Router

Hi folks, I have a bit doubt about Virtual Routers.
Can I usage an distribuition as Virtual Router? Os is there any special think in Alpine Linux image?
My idea is usage Vyatta image or FreeBSD, PFSense, and others (supported by vSphere)

Is it possible?

Best regards,


Hi Carlos,
though I’m no expert with vcenter I’ll try to give you my two cents.

In short I’d recommend you to use the Virtual Router, which is an Alpine Linux image created by the OpenNebula team, for many reasons:

  1. It’s available in the marketplace,
  2. It’s documented and… that is always great :wink:
  3. It uses quagga which is what runs in Vyatta and VyOS.
  4. And it should work with contextualization so no more headaches

Now a longer explanation :slight_smile:

The best with OpenNebula is that you can use what you most love. You may find an appliance that a user has uploaded to the marketplace or you can create your own and share it with the rest :wink:. There are less appliances for VMWARE in the marketplace but we can change that!

I uploaded some time ago the Vyatta and VyOS images in the marketplace as I had used it in the past… but only for KVM. I had to find out how to add contextualization so IP, networks and the networking stuff was included automatically when instantiating the virtual machine. As Vyatta was discontinued by Brocade I’d suggest you not to use it as the last version was 6.5 and no more updates have been released. If you like Vyatta please use VyoS instead which is a fork of VyOS. So if you choose any router I recommend you to use contextualization. I created a post about it so you can know what I needed in my case to create those images for the marketplace at

Once again try the Virtual Router and if that doesn’t suit you maybe we can try to create together a new appliance.


Hello Miguel,

Thank you so much by your comment, It was very nice for me.
I realize some tests with “Virtual Router” image and it works very nice.
Now I 'm testing “PFSense” as router/firewall, and it is working very well too, except “contextualization”

I 'm deciding if I will work with contextualization package or not in my env. I will look your code to maybe write something to PFsense :slight_smile:

Thanks a lot @mcabrerizo !!!



I tried to create a PFSense image a long long time ago I’ll try to look for my notes if they haven’t lost in Oblivion. I think the tricky point is to find when and where is the right place to put the contextualization package in pfSense. Usually it won’t be difficult to create one for PFSense/xBSD using the Linux/Unix examples provided by the OpenNebula team.

If I can help you in any way let me know!



Nice to know that you tried it.
I will try investigate better it, and report you about my tests.
Currently the image it is working without problerm.

look :slight_smile:



Thanks for sharing!


It seems PFSense does not identify the with label CONTEXT

Like this this one checking



Sorry to hear that :frowning:. In a few days I’ll try to have time to play with vCenter and I’ll try to create a pfSense appliance. If I get it working I’ll update this topic.

See ya!

Hi @mcabrerizo,

I appreciate your help!!

See ya!!