Virtual Router Localhost Login

Hey everyone, new to OpenNebula and am having an issue with a virtual router I created. When I VNC into it, I am prompted with the localhost login screen. I have tried multiple passwords with no success, and have tried setting ROOT_PASSWORD and SSH_PUBLIC_KEY but neither of the passwords I set for those variables work.

The VMs I created do not prompt me with a login if that makes any difference. Also, I am unable to ssh into the router from the host machine as it gives the error no route to host.

I just need a way to configure routing tables for the router.

Hi John!
If you’re talking about OpenNebula’s Virtual Router (which is an alpine based appliance) I would start with the docs about OpenNebula’s Virtual Router here

You can use the virtual router to route between the virtual networks that you create in OpenNebula. Basically you would start creating the virtual networks and then add interfaces on your virtual router so it’s connected to them. When creating a virtual network you would generally need a bridge so you can connect your VMs to your physical networks

The virtual router should be configured from Sunstone (OpenNebula web interface) or OpenNebula CLI (onevrouter command) and you wouldn’t need to access the command line interface but in any case I have no idea of what the root password is, sorry. I may be wrong but I don’t think that ROOT_PASSWORD and SSH_PUBLIC_KEY context variables work with the Virtual Router.


What is default localhost login and password for alpine virtual router instance. When I try to connect using VNC, it asks for login id and password. What is it? How to reset it?

There is no root password. You need to configure the ssh keys in the CONTEXT, and connect as root user through ssh.

Thanks jeovanevs

did this work? If yes, what was the procedure?
We have an issue with the network, and need to troubleshoot some steps on Alpine Router.

1 Like