VMs disappeared after shutdown

Hi!

v.4.12
I have 76 active VMs.

  1. Reboot host machine hardly (some failures)
  2. After reboot start VMs - that’s ok.
  3. Shutdown together all 76 VMs and they dissappeared o_0

What’s wrong?
This is a bug or am I doing something wrong?
This behavior is very scary :scream:

UPD: ACPI disabled

source: http://docs.opennebula.org/4.12/user/virtual_resource_management/vm_guide_2.html#terminating-vm-instances

Terminating VM Instances…
You can terminate a running instance with the following operations (either as onevm commands or through Sunstone):

shutdown: Gracefully shuts down a running VM, sending the ACPI signal. Once the VM is shutdown the
host is cleaned, and persistent and deferred-snapshot disk will be moved to the associated datastore. If after a given >time the VM is still running (e.g. guest ignoring ACPI signals), OpenNebula will returned the VM to the RUNNING state.

shutdown --hard: Same as above but the VM is immediately destroyed. Use this action instead of shutdown when the VM doesn’t have ACPI support.

that is expected behaviour - see documentation

Hello, i see documentation, and know that “shutdown --hard” destoy VMs, but i use “shutdown” only.
So i ask, is there bug or error?

that’s the expected behavior, --hard refers to gracefully shutdown the VM
or not

I personally have not encountered a dissapearing VM when I just use “shutdown”, to be honest.
As far as I know, there is no known bug like this. If you deploy another VM, and use “shutdown”, can you reproduce the issue ?

I have tried to reproduce the situation, but now everything is fine. Trying, but still wonder why it happened.

@GabrielDias,

I had the same “problem” when started using ONE. For OpenNebula:
shutdown -> “bring down” the VM and release the image, therefore the image state will become READY and VM will removed from VM list.
power off -> “bring down” the VM only. You can power on by “resume”

The Devs should rename “shutdown” to destroy or delete.

splash forum@opennebula.org writes:

The Devs should rename “shutdown” to destroy or delete.

Or terminate as it was proposed at the TechDay Paris.

I just open an issue[1] for this.

Regards.

Footnotes:
[1] http://dev.opennebula.org/issues/3932

I did shutdown on all running VMs on a staging, it all disappeared, the VM images were wiped off too. That was scary. Now i tried reinstalling the opennebula, i am getting GPG error for the download from opennebula.org. It is worrisome. The images were on a parallel file system on shared setup. The OS were all Ubuntu 14.04.

That was one messed up system. It was not due to opennebula.