VMS not show in Opennebula Sunstone 5.11.8

I’ve recently upgraded Opennebula from 5.10.1-1 to 5.11.80-1. I’ve upgrade the onedb (I’m using sqlite) and restarted the services. All looking good except I am unable to see my VMs in the Sunstone web interface. The VMs are working just fine, they are just not shown there. Also I’m able to see those VMs by using onevm list on the server. Everything else looks working just fine. Any ideeas?

Hello @bms8197
Thanks for the feedback! Very appreciated that you have tested the beta upgrade. This bug is solved in master, so in the RC it will be solved too.

The possible error that happens is fixed in the following commit
To make sure you have the beta version, you can run the command oned -v.


Yes, it seems that I’m using the beta version.

OpenNebula 5.11.80 (3e1b2be2) is distributed and licensed for use under the terms of the

I was not planning to use this beta version but since it’s pretty difficult to build the 5.10.5 packages and the official repo only has 5-10.1 I thought it would be nice to try something else.

I’ll check the commit to see if I’m able to fix it! Thanks!

Are you sure that’s the right commit? As far as I can tell it’s related to missing IPS not the vms. How do I apply that to the current install (from the official beta packages)?

I’ve applied the modified code from that commit but I see no difference. The VMs are not shown on the Dasbhoard tab nor in the Instances -> VMs tab.

Can you show me a screenshot with the browser console open (f12) in the tab console? For me to see the error you mean

The screenshot above is after installing opennebula-sunstone package

This one bellow is after applying the code from that commit (file vm.js)

I’m on MacOS Catalina, latest version, Firefox browser

I think you have the sunstone in production mode, in that case do the following use the commit mentioned by @sbetanzos then use the following commands.

cd /usr/lib/one/sunstone/public
cp /dist/main.js /dist/main.bk.js
bower install --force --allow-root --config.interactive=false
cd bower_components/no-vnc/ && npm install && ./utils/use_require.js --clean --as amd && sed -i -e "s/'\.\//'\.\.\/bower_components\/no-vnc\/lib\//g" lib/rfb.js )

when finished please restart the sunstone service

I’ve reverted back to opennebula-5.10.1-1 from the official repo. Way too many things to configure and modify but thanks for the update!