VNC irresponsive, cannot login

I have downloaded the centos’ opennebula sandbox and it is connected to another host (I can SSH it without that it prompts for password). I imported the image “debian-7.1-amd64-kvm” from the marketplace and I created a new VM.
The VM is in status “running”, but when I open the VNC console this is what I get:!4430&authkey=!AFTK8TAr9pBUzGI&v=3&ithint=photo%2Cpng
The VNC console is empty, it’s not even logged and it doesn’t accept mouse/keyboard events. I cannot even type a command !!

not sure if this helps, but is there an input device selected (like a USB mouse or a tablet) in the input/output tab of the template? That might explain lack of mouse/keyboard.

the log of the VM should be in /var/log/one/(number of VM).log - and any details regarding novnc-proxy can be found in /var/log/one/novnc.log
If you want to debug the novnc-part, use the command from the beginning of the log to get more output in your console.
Which is something like: "python /usr/share/one/websockify/ --target-config=/var/lib/one/sunstone_vnc_tokens 29876"
This should show errors, if any, on console.

1 Like

I tried to add a USB tablet and mouse, and it worked once but now I’m trying it again with a persistent image and despite the keyboard/mouse work I’m in the same situation: it just doesn’t log in. It logs all the stuff (e.g.: starting configure network device [ok], etc…), but then it never allows me to type commands.

ok, if the input of any command via keyboard or mouse movement is ok, then that part is ok.

If you’re stuck at the grub screen, as in the original screenshot you posted, maybe the image you are using (persistent or non-persistent) doesnt boot ? Or do you get a normal linux booting process as expected ?

maybe input and problems with (persistent) images are separate problems and not related ?
Does an image from marketplace boot normaly, or is anything you start in “cant find grub” ?

It seems you’re having 2 separate issues;
1 cant use keyb/mouse in a VM, but adding a tablet or mouse in the template worked, right?
2 The image problem: the disk you’re using is probably mounted wrong.
The screenshot you added is a PC that cannot find its operating system on the disk, like any bios on a real would show. The reason you cannot type a command, is because there is no operating system to receive it :slight_smile: When you select the Virtual Machine, click on the tab called “Log” to see what’s wrong.

For the 2nd image-problem; you need to have a correct template / correct image / correct setup to be able to deploy a VM succesfully. So if you download an image from marketplace and you use a raw image as a qcow2 image, or a datablock as a CD, things won’t work.

here is what you need to know: