Windows password ignored


I’ve created a Windows 2019, context drivers installed. Created in the template a “USER INPUT” of type TEXT called “PASSWORD”. I instantiate a new VM, but can’t RDP with user Administrator and the input password.

In the file I see PASSWORD=$PASSWORD instead of my user input value.

Any pointers? Thanks

Hi @Nux ,

First, you should know that there is an issue related to this issue in github.

But you have the option to instantiate with plain-text password.

  • You should disable password encryption by comment out/removing VM_ENCRYPTED_ATTR ="CONTEXT/PASSWORD" from oned.conf file.

  • The VM template should have a content like the following:

   PASSWORD = "M|text|Password| |root",
   USERNAME = "M|text|Username| |root" ]
  • Once you instantiate the template, you should see the result in the VM:
   PASSWORD = "root",
   USERNAME = "root"]

let me know if it worked,
regards :rocket:

1 Like