[4.11] spice is not refreshing

spice console is not refreshed

FIXME: Unable to interpret bitmap of format: 22: Unknown message type 304!FIXME: Unable to interpret bitmap of format: 2

Any idea?


Does it work using another spice client?


Good idea. I’ve just tried with virt-manager, same problem. Seems even worse… I will check if the VM xml definition is fine. Or may be the CentOS7 image from marketplace is missing something about SPICE…

sorry in fact it starts to work fine with virt-manager but as soon as I use the spice html5 agent, display refresh and inputs are messy and unusable, in both sunstone and virt-manager… But when I stop and close the spice html5, after a while, it’s back to normal in virt-manager.

Here are more logs:

Connected to ws://
Channel type 9 unknown.
Channel type 9 unknown.
Channel type 9 unknown.
Channel type 6 unknown.9: No message handlers for this channel; message 101
keyboard channel is insecure
Unimplemented function 108(Inval All Palettes) [ further notices suppressed ]
Unimplemented function 102(Display Mark) [ further notices suppressed ]
MediaSource API is not available5: Unknown message type 102!
FIXME: Unable to interpret bitmap of format: 22: Unknown message type 304!

I’ve just enabled spice console and add ‘fr’ keymap. Any idea?

What OS are you using in the guest machine?

I tried with CentOS 7 and Fedora 21. I can try debian7 image from marketplace too.

Just to mention that we upgrade from 4.10.2 to 4.11. Not sure if it helps. You don’t have this problem with the spice console in sunstone? We tried with chromium and firefox same problem.

Same on 2 different opennebula platforms.

Hi it looks like the problem is related to the text console of the guest. Could you try using a graphical environment?

Looking at the spice-html5 code, it seems that the bitmap format returned by spice is not supported by the library

function convert_spice_bitmap_to_web(context, spice_bitmap)
    var ret;
    var offset, x;
    var u8 = new Uint8Array(spice_bitmap.data);
    if (spice_bitmap.format != SPICE_BITMAP_FMT_32BIT &&
        spice_bitmap.format != SPICE_BITMAP_FMT_RGBA)
        return undefined;

Probably one of the maintainers of the spice-html5 library can help us

Yes searching the web seems to point to some people having the same problem. In graphical environment it’s working quite better, but still not fully useable. There are popup boxes saying “no map for XXX” (like the alt gr key) and some time it hangs. Have to use virt-manager to get back in control. Only try with CentOS7 and Gnome env.

Yes, as they state in the spice web it’s just a prototype and lot of work have to be done yet.

We will update it as soon as a new version is released

Thank you for your feedback

Good to know that it’s still a prototype. At least we can still use VNC and hope this html5-spice agent will be mature soon.
Thanks for your help