Access lan network to public network get stuck on tls handshake

Hi everybody

I have a simple bridge for public interface and simple vxlan for private networks (not openvswitch) .

I’ve also had a router pfsense with two interfaces ( private interface is vxlan and public interface is simple brige)

I’ve also enabled mac and ip spoofing.

All other vms’ has just one interface ( at the same vxlan with pfsense ) and the gateway is pfsense’s ip ( I set a masquerade nat rule on pfsense to give public access to vms)

At the moment, every vms can communicate to each other without any problem and also has access to internet via pfsense.

the problem is that although I can telnet to 443 port, all vms get errors related to TLS handshaking and get stuck when connecting to them but when I assign a public interface to vms directly, the problem is solved so I think the problem is related to vxlan not to datacenter.

You guys do you have any idea?

With vxlan all vms see each other with (ping) but network suddenly stucks when I run a command like (top or htop) or open vi editor . Does anyone have any idea?