Cannot in any way upload image

After three consecutive full instalations from the scratch, I cannot in any way upload an image from which to make a template and start a virtual machine.
The instalation is on one bare-metal server. I make Single Front-end + KVM Node instalation.
The error is the same both through sunstone and through CLI.
Through SSH I upload .iso into /var/tmp/ perform oneimage create… and the same error again.
I attach details about the server, the instalation and the result from the error.
If you need any further information, don’t hesitate to ask.
I’m asking for help!
I didn’t find such an error in the forum. I found similar but I couldn’t solve my problem.
Thank you in advance!

$ hostnamectl
Icon name: computer-server
Chassis: server 🖳
Operating System: AlmaLinux 9.2 (Turquoise Kodkod)
CPE OS Name: cpe:/o:almalinux:almalinux:9::baseos
Kernel: Linux 5.14.0-284.25.1.el9_2.x86_64
Architecture: x86-64
Hardware Vendor: Supermicro
Hardware Model: Super Server

$ df -h
Filesystem Size Used Avail Use% Mounted on

/dev/nvme0n1p3 32G 5.6G 27G 18% /
/dev/nvme0n1p5 195G 1.4G 194G 1% /datastores

$ ls -la /datastores/
drwxr-xr-x 4 oneadmin oneadmin 24 Aug 30 16:58 .
dr-xr-xr-x. 19 root root 273 Aug 30 14:40 …
drwxr-xr-x 2 oneadmin oneadmin 6 Aug 30 16:58 1
drwxr-xr-x 2 oneadmin oneadmin 6 Aug 30 16:58 2



$ egrep “DATASTORE_LOCATION” /etc/one/oned.conf

$ su - oneadmin

$ pwd

$ ll /var/tmp/

-rw-r–r-- 1 oneadmin oneadmin 1632679936 Aug 30 18:35 OPNsense-23.7-dvd-amd64.iso

$ oneimage create --name OPNsense-23.7-dvd --path /var/tmp/OPNsense-23.7-dvd-amd64.iso --type CDROM --datastore default

[one.image.allocate] Cannot parse image SIZE: /var/lib/one/remotes/datastore/fs/…/ line 446: (1632679936 1632679936+1048575)/1048576: missing `)’ (error token is “1632679936+1048575)/1048576”) Cannot determine size for /var/tmp/OPNsense-23.7-dvd-amd64.iso

Looks like the ISO could be faulty. Can you mount it ? What do you get when executing file /var/tmp/OPNsense-23.7-dvd-amd64.iso.

If the ISO looks okay, try grabbing this file then replace /var/lib/one/remotes/datastore/ with it. Then try again.

Thank you so much for the answer!
After I followed the instructions, the result is:

su - oneadmin
$ pwd

$ cd /var/lib/one/remotes/datastore/
$ ll

-rw-r----- 1 oneadmin oneadmin 18672 Dec 21 2022

$ mv


$ ll

-rw-r----- 1 oneadmin oneadmin 18656 Sep 8 12:59

$ diff

< echo “$($QEMU_IMG info “${1}” 2>/dev/null | sed -n ‘s/.(([0-9]) bytes).*/\1/p’)”

echo "$($QEMU_IMG info --output json "${1}" | jq '."virtual-size"')"

I checked again:

Sunstone => Create Image => Upload

[Z0][ImM][I]: Image (0) copied and ready to use.

Problem solved!
It works as expected.

Once again, thank you for your assistance!