Cloning from bad host!

i have a custom image in Datastore on server1 (SSH non-shared), NOT on Front-end, i am sure ! but when instantiate… OpenNebula tray always to clone from Front-end and not server1, why ?

Mon Dec 11 05:06:48 2017 [Z0][VM][I]: New state is ACTIVE
Mon Dec 11 05:06:48 2017 [Z0][VM][I]: New LCM state is PROLOG

Mon Dec 11 05:08:01 2017 [Z0][TM][E]: clone: Command “scp -r
server1.local:/home/one/102/7/disk.1” failed:
/home/one/104/640277e5604b8242b456cd4cf87ac35d: No such file or

this should be

“scp -r server1.local:/home/one/104/640277e5604b8242b456cd4cf87ac35d server1.local:/home/one/102/7/disk.1”

Hi Saif,

You should take a look at the configuration options of the TM_MAD. And don’t forget to restart the opennebula service after altering the configuration files.

Best Regards,
Anton Todorov

That conf options can be also specified in datastore template, so no need to edit manualy and restart…

Please post your datastore template. Both, image and system types

Fixed, thank you Anton, thank you Kristian, :slight_smile:

After reading configuration options, i found that SSH Transfer Mode is used for cloning image from Frontend to Hosts (i don’t know if this is configurable) , but Shared & Qcow2 Transfer Modes is what i need (using shared image in the server1.local)

So, i create a new Datastore Shared Mode as FilesSystem

TM_MAD : qcow2

Thank you again :slight_smile: