Error while importing VM Template

Hello all,

I am running newly installed Opennebula-6.0.2, and exploring functions for industrial use.

what worked fine:
1)Imported Clusters successully
2)Imported Networks successfully
3)Imported Datastores succesfully
4)Imported Disk Images successfully

Whats not working:
1)Importing VM Template.
-Initially I have successfully imported one VM-Template successfully.

But after that not able to import any more VM-Templates.

I have tried another VM teamplate moved to same datacenter as 1st one which I had imported successfully.
Also set the same VLAN as 1st template.

but still not able to import 2nd template.

Appreciate your help .

Versions of the related components and OS (frontend, hypervisors, VMs):
Opennebula - 6.0.2

Steps to reproduce:
$onevcenter import vm-50614 -o templates -h 0

Current results:
$ onevcenter import vm-50614 -o templates -h 0

  • Template: centos6Final

    For faster deployment operations and lower disk usage, OpenNebula can create new VMs as linked clones.
    Would you like to use Linked Clones with VMs based on this template (y/[n])? n

    Do you want to specify a folder where the deployed VMs based on this template will appear in vSphere’s VM and Templates section?
    If no path is set, VMs will be placed in the same location where the template lives.
    Please specify a path using slashes to separate folders e.g /Management/VMs or press Enter to use defaults:

    This template is currently set to launch VMs in the default resource pool.
    Press y to keep this behaviour, n to select a new resource pool or d to delegate the choice to the user ([y]/n/d)? y

Error: Couldn’t import vm-50614 due to
There was an error trying to create an image for disk in vcenter template. Reason: datastore not found for VM’s device!


Expected results: