Hypervisor OS's


I am adding additional hypervisors to our ON cluster… currently utilizing Debian 9 for compute nodes, however, is it possible to add additional compute nodes that are running CentOS7? I am not sure if the hypervisor OS’s need to match the front-end OS (Debian 9 also), or not.



Shouldn’t be an issue, I’m using Ubuntu 14.04 LTS boxes together with 16.04 LTS boxes myself; simply ensure that your shared storage setup works (i. e. UID/GID of oneadmin user is same on Debian 9 and CentOS 7) and your networking setup is sound.

So I figured i’d give it a shot, mixing operating systems in the same cluster…
I’ve deployed a CentOS7 compute node, and added it to the existing cluster containing Debian 9 compute nodes. Everything seemed to fine until i tried to boot up a VM that i migrated over to it… with the following error:

Thu Jan 18 11:01:44 2018 [Z0][VMM][I]: error: Failed to create domain from /var/lib/one//datastores/0/668/deployment.2
Thu Jan 18 11:01:44 2018 [Z0][VMM][I]: error: Cannot check QEMU binary /usr/bin/qemu-system-x86_64: No such file or directory

The file /usr/bin/qemu-system-x86_64 DOES exist on the Debian 9 compute nodes, but does not exist on the CentOS7 compute node.

I think you’re setup of just different Ubuntu versions, is close enough on the OS level that file locations are all still the same, and probably why you’re not seeing a problem.

I wonder if anyone has been able to mix completely different OS flavors as compute nodes…