Issue with Custom SSH Port Not Being Used for VM Cloning in OpenNebula

Hello OpenNebula Community,

I am experiencing a challenging issue with OpenNebula where it fails to use a custom SSH port for cloning VM images. Despite configuring the custom port in the .ssh/config file for the oneadmin user, OpenNebula continues to default to using port 22 during the cloning process. Here are the specifics of my setup and the troubleshooting steps I’ve undertaken:

  • Custom SSH Port Setup: The SSH service on the host is configured to listen on a custom port (not 22). This setup works correctly when I manually SSH into the host.
  • .ssh/config Configuration: The oneadmin user’s .ssh/config is configured as follows:
    Host *
    StrictHostKeyChecking no
    UserKnownHostsFile /dev/null
    Port [custom_port]
  • Hostname and Datastore Configuration: The /etc/hosts file has been correctly configured, and the datastore parameters are set with TM_MAD = ssh.
  • Successful Connection to Host: The connection between the OpenNebula frontend and the host using the custom SSH port works without any issues. The host was added normally to the frontend, and the host monitoring is functioning correctly.
  • Permissions and OpenNebula Version: The oneadmin user has the appropriate permissions for the .ssh/config file. I am using OpenNebula version [mention your version here].

Despite these settings, OpenNebula insists on using the default SSH port 22 for VM cloning operations. The logs don’t seem to provide any clear indication as to why this is happening.

I’m seeking insights or suggestions on why OpenNebula is not using the specified custom SSH port for cloning operations. Are there additional configurations or steps I should consider to address this issue?

Thank you in advance.


Is the ~/.ssh/config file set up in all of the hosts? Can you execute the scp command on a host to copy the file from the frontend?

Thank you