Message: Method Not Allowed message when attempting connection to sunstone server with self signed cert

When attempting connection to sunstone server with self signed cert, we get the following message from web browser:

Error response
Error code 405.
Message: Method Not Allowed.
Error code explanation: 405 = Specified method is invalid for this resource…

out sunstone-server.conf file has this entry:
:vnc_proxy_port: 29876
:vnc_proxy_support_wss: yes
:vnc_proxy_cert: /etc/one/certs/one-tornasol.crt
:vnc_proxy_key: /etc/one/certs/one-tornasol.key
:vnc_proxy_ipv6: false

and .crt and .key do exist. we generated them ourselves. (from

any help would be greatly appreciated. This is a NEW install, so it has never worked for us yet.

hi Paul,

had this before and added this to the test-env. notes:

when using a test-environment, so probably a self-signed certificate, you need to get trust for the cert. in your browser. Load the page: and accept the security risk (especially firefox), afterwards encrypted VNC traffic over the websocket is properly handled and encrypted. A “real” certificate does not need this workaround.

Using tcp port 443, and finding a self-signed, non-accepted certificate it will trigger the “create exception” option in a browser. But for secure VNC traffic, using tcp port 29876, it doesnt, so you need to do that manually once, and then it will work as expected (and secure).

EDIT: because you post your VNC settings, I assumed you mean encrypted VNC traffic, right ?
Accessing Sunstone itself (so not just VNC) is best done using a proxy, like apache or nginx. See this topic for configurations: VNC with Sunstone behind Nginx Proxy

hope this helps!

Yes, it did help, and thank you for your input!