Need Help Installation version 4.10 in Centos 7

Dear Forum,

I am installing opennebula 4.10 in Centos 7, following the quick installation guide that have 3 main steps. The process is good and clean, until about to end to step 2. The step 2.3 configuring the network and bridge not done yet since i am using wireless interface at the moment.

here is the link of documentation that i follow as installation guide.

I am installing in a new machine hardware with centos 7 minimal install, watching every step output in the screen i believe that no error is generated.

beside the server hardware machine i have one laptop and small wireless network with internet access, i can pink to the server from my laptop, the server machine can access the internet also my laptop.
I can also ping from server machine into my laptop ip address.

The question/the problem:
To do the step 3 group, the documentation guide said that i can do it from the frontend, http://frontend:9869, but i don’t know how exactly where to put this, in my laptop browser or i must install the httpd sevice in the server machine then open browser in the server machine?, i assume that it should be able to access it from my laptop.
I already edit the
/etc/one/sunstone-server.conf file and change :host: to
but when i access put this in my laptop browser IP:9869 (i replace the with ip address of server machine interface), but i can not connect it with this error

Unable to connect

Firefox can’t establish a connection to the server at 192…43.126:9869…

I have been googling around, but can not find the answer yet.

I am very new with this, please help how can i have the front end functioning to go to step 3 and success with the installation to up and running.

Thank you and regards,

Hi bunhin,

Please check Opennebula services on the server, wether it started or not .
systemctl status opennebula
systemctl status opennebula-sunstone netstat -tlunp | grep 9869

Hi Jamessarems,

Thank you for your response.
The status of opennebula and opennebula sunstone is active and running and no error indicated, never check the netstat, just now i reboot the server and check again the result are:

  1. opennebula is active and running
  2. opennebula-sunstone is active and running
  3. response from netstat -tlunp | grep 9869 is like this:

tcp 0 0* LISTEN 2070/ruby (9869 shown in PINK COLOR)

test again to access from my laptop browser – still unable to connect
i test using comand line (links) browser connection refused

I then do adding port to the firewall with this command

firewall-cmd --zone=public --add-port=9869/tcp --permanent
firewall-cmd --reload

Then test it again, the result still unable to connect

The selinux is already in permissive mode since the intallation begin
The firewald or iptables not installed/loaded when installing

i also check aggain (yesterday already) like this:
#su oneadmin
$onevm list
it is resulting the empty list

I do not know the next trouble shooting step from now and still googling around (but it seem no luck finding similar issue and solved)

Please help again

Thank you,
Bun Hin

Just minute ago i change again the host in sunstone-server.conf file to become
(previously i try with and then with specific ip of my network)
now become ok, (Happy me), then i prompted with login screen

I dont know user and password to put in the logian form.

i can open /var/lib/.one/ …some …_auth file are there, but it seem very long (like hashed) password, which one is suitable?

Ok now solved.

Thank you again Jamessarems