Oneflow Server not working after upgrading from 5.4.12 to 5.5.80 beta on CentOS 7

Please, describe the problem here and provide additional information below (if applicable) …

We are trying to test OpenNebula upgrade from v5.4.12 to v5.6 Beta (5.5.80) on our testing environment, and all the upgrade proccess seems to run smoothly, but when we try to check oneflow running services or oneflow service templates we allways get this error: [] Error getting document [ID]
We’ve tried to edit oneflow-server.conf using almost every possible combination of localhost, the server IP address, on bot :host: and :one_xmlrpc: fields

Versions of the related components and OS (frontend, hypervisors, VMs):
Opennebula 5.5.80 + mariadb-5.5.56-2.el7.x86_64 on same VMware VM on a CentOS 7.4
Steps to reproduce:
Migrate from a working OpenNebula v5.4.12 environment to OpenNebula v5.5.80 beta
Current results:
Oneflow not working via Web UI nor CLI
Expected results:

Hello @josemiguelcasado,

Yes, this is a bug in the update process. We’ve open a ticket in github to resolve it:

Thanks for the report.

1 Like

thanks for opening the ticket.

Are you going to upload a new beta version when it’s solved or will you publish a workaround?

Best regards.


We are going to publish the RC in this week.

If you need a workaround because it’s urgent, just remove the LOCKED attribute from the oneflow template.


Thanks for your reply, AbelC.

As we are doing this upgrade for testing a future upgrade on a production environment, we are going to try the workaround you propose. Could you please indicate how can we remove that LOCKED attribute?

We have found that attribute using oneflow show ID -j but we haven’t been able to update it (json format seems not to be permitted for oneflow update command).

Via Sunstone we haven’t found that attribute.

Best regards.

I’m still having this issue with 5.6.2:

==> oned.log <==
Sat Dec 15 16:36:27 2018 [Z0][ReM][D]: Req:8160 UID:1 invoked , 99
Sat Dec 15 16:36:27 2018 [Z0][ReM][E]: Req:8160 UID:1 result FAILURE [] Error getting document [99].

==> oneflow.log <==
Sat Dec 15 16:36:27 2018 [E]: [LCM] Error getting Service 99: [] Error getting document [99].

Don’t know yet if it’s reproductible. Any idea ?

Best regards,