Opennebula GlusterFS snapshot


is snapshoting in VM that runs on GlusterFS cluster possible ?

VM runs like this :
/usr/bin/qemu-system-x86_64 -name one-37 -S -machine pc-i440fx-trusty,accel=kvm,usb=off -m 2048 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid 8147148e-2405-4ba7-94cb-c402dc2d1424 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/one-37.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -boot strict=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2

-drive file=gluster://node1:24007/vmvol/37/disk.1,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=2
(this is HDD)

-drive file=/var/lib/one//datastores/112/37/disk.3,if=none,id=drive-ide0-0-1,readonly=on,format=raw,cache=none -device ide-cd,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1,bootindex=3
(instalation CDROM image)
-drive file=/var/lib/one//datastores/112/37/disk.2,if=none,id=drive-ide0-1-0,readonly=on,format=raw

-device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=24,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=02:00:d9:4b:40:bb,bus=pci.0,addr=0x3,bootindex=1 -netdev tap,fd=25,id=hostnet1 -device rtl8139,netdev=hostnet1,id=net1,mac=02:00:0a:c8:64:01,bus=pci.0,addr=0x4 -vnc -device cirrus-vga,id=video0,bus=pci.0,addr=0x2 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5

This is snapshot error :
[Z0][VMM][I]: error: unsupported configuration: internal snapshot for disk hda unsupported for storage type raw



Yes it is possible. We were used glusterfs as shared storage and snapshot process are worked fine. May be it is because of “raw” disk format . Use qcow2 instead of using raw.


how to I force opennebula template to create qcow2 images instead raw ? I tried to define “qcow2” in driver section of disk storage in Templates. This template is used to instantiate new VMs.



In my case it is like ,

In storage section >>
Volatile Disk >> Formart : qcow2 Advanced Options >> Driver : qcow2 , Cache : writeback .

1 Like