Remove a zombie VM

Opennebula show me the VM id28 is using my image but the vm id28 isn’t in the instance panel.
How can I delete it ?

One VM say:

onevm show 28
VIRTUAL MACHINE 28 INFORMATION
ID : 28
NAME : test1
USER : oneadmin
GROUP : oneadmin
STATE : DONE
LCM_STATE : LCM_INIT
RESCHED : No
START TIME : 12/13 16:32:29
END TIME : 12/13 16:38:45
DEPLOY ID : -

VIRTUAL MACHINE MONITORING

PERMISSIONS
OWNER : um-
GROUP : —
OTHER : —

VM DISKS
ID DATASTORE TARGET IMAGE SIZE TYPE SAVE
0 Ceph-image vda CentOS 7 - KVM -/8G rbd NO
1 - hda CONTEXT -/- - -

VM NICS
ID NETWORK BRIDGE IP MAC PCI_ID
0 vlan1 onebr.1 10.1.255.0 02:00:0a:01:ff:00

SECURITY

NIC_ID NETWORK SECURITY_GROUPS
0 vlan1 0

SECURITY GROUP TYPE PROTOCOL NETWORK RANGE
ID NAME VNET START SIZE
0 default OUTBOUND ALL
0 default INBOUND ALL

USER TEMPLATE
LOGO=“images/logos/centos.png”

VIRTUAL MACHINE TEMPLATE
AUTOMATIC_DS_REQUIREMENTS="“CLUSTERS/ID” @> 0"
AUTOMATIC_REQUIREMENTS="(CLUSTER_ID = 0) & !(PUBLIC_CLOUD = YES)“
CONTEXT=[
DISK_ID=“1”,
ETH0_CONTEXT_FORCE_IPV4=”",
ETH0_DNS=“10.1.30.24”,
ETH0_GATEWAY=“10.1.0.255”,
ETH0_GATEWAY6="",
ETH0_IP=“10.1.255.0”,
ETH0_IP6="",
ETH0_IP6_PREFIX_LENGTH="",
ETH0_IP6_ULA="",
ETH0_MAC=“02:00:0a:01:ff:00”,
ETH0_MASK=“255.255.0.0”,
ETH0_MTU="",
ETH0_NETWORK=“10.1.0.0”,
ETH0_SEARCH_DOMAIN="",
ETH0_VLAN_ID=“1”,
ETH0_VROUTER_IP="",
ETH0_VROUTER_IP6="",
ETH0_VROUTER_MANAGEMENT="",
NETWORK=“YES”,
SSH_PUBLIC_KEY="",
TARGET=“hda” ]
CPU="1"
GRAPHICS=[
LISTEN=“0.0.0.0”,
TYPE=“vnc” ]
MEMORY="768"
OS=[
ARCH=“x86_64” ]
TEMPLATE_ID="7"
VMID=“28”

onevm recover 28 --delete -v
VM 28: recovering

But it’s still here !

try to deploy again, then destroy