Solaris 11: network does not work on opennebula


Network in Solaris 11.3 on opennebula does not work - packets from Solaris’s VM reaches network, but Solaris does not see any incoming packets (checked by dlstat, snoop and netstat -in).
I tried to change network adater type to rtl8139, e1000 and pcnet without any results.
I found similar problem for Solaris 11 in KVM:

But I don’t known, how to implement this recommendation on opennebula - I tried to disable APIC feature, but without any result.

Any ideas?

In opennebula disabling apic can be done at the template level, but you say that this does not solve the problem?

$ cat
RAW = [ DATA = “<cpu mode=‘host-passthrough’><feature policy=‘disable’ name=‘x2apic’/></cpu>”, TYPE = kvm ]

$ onetemplate update solaris -a

Changing APIC to “no” in VM’s features does not make any changes in libvirt deployment file…

I applied
<cpu mode='host-passthrough'><feature policy='disable' name='x2apic'/></cpu>
to VM’s properties, but on machine’s start got this error:
Mon Aug 21 14:03:48 2017 : Error deploying virtual machine: Could not create domain from /var/lib/one//datastores/0/11/deployment.1
I tried to manually import deployment file into libvirt:
# virsh define /var/lib/one//datastores/0/11/deployment.1 error: Failed to define domain from /var/lib/one//datastores/0/11/deployment.1 error: XML error: Non-empty feature list specified without CPU model

It’s looking as bug in libvirt, and correct (?) one for RAW data is:
<cpu mode='host-passthrough'> <model fallback='allow'>core2duo</model> <feature policy='disable' name='x2apic'/> </cpu>
Machine starts, but network still does not working :frowning: