Virtual Networking

Hey OpenNebula people!

So, I decided to run an OpenNebula setup, and so far I’m very happy with it. I am running into one problem though I hope you can help with.

I have a virtual network defined, and I’m using OpenvSwitch, and I have the bridge defined. I set my first IP range up, and the VMs are working fine. I receive a new IP range from my datacenter, I add it onto the same virtual network, but I added custom attributes for gateway and network mask. When I provision VMs on this new IP range, no traffic flows on the these IPs at all.

Have I missed a critical step, or is it more likely that there is something wrong on the datacenters side?


I guess the subnet mask is not setting up at the VM’s. Try using Context option in VM templates.
Add CONTEXT=[ETH0_MASK=“Your subnet mask” ] in your VM templates file.
It might work for you, I used it with older version of opennebula (3.8) and it worked.
Good Luck.

I don’t think that is the problem. In the ifcfg-eth0 file of the server, it has the right subnet listed. I could be wrong though, so I will give this a try in the morning. Most importantly though, thank you for your reply :). I truly appreciate it.

If the subnet is correct in eth0 config file, then it’s not the problem. You said you are not able to pass any traffic on the IP’s, did you tried to ping the IPs? What was the o/p.
Check the log messages on VM’s as well as nebula server.

It was a problem with the DataCenter, as I thought it was. They forgot to update the ACL to allow traffic to pass.