[Solved] Duplicate entry 'xx' for key 'name'


Since today i have the oned.log spammed with multiple lines per second on all 3 cluster nodes with the following message:
Thu Feb 8 15:55:14 2018 [Z0][ONE][E]: SQL command was: INSERT INTO user_pool (oid, name, body, uid, gid, owner_u, group_u, other_u) VALUES (183,‘user.name’,‘183105105Devuser.name<AUTH_DRIVER></AUTH_DRIVER>1<TOKEN_PASSWORD></TOKEN_PASSWORD>’,183,105,1,0,0), error 1062 : Duplicate entry ‘user.name’ for key ‘name’

We are using ldap auth and for me it looks a bit like the login name in ldap and ON are in some wired shape. The user tells me that he needs to login with Capital letter for his first name but not for the last name, in ldap there is capital case on both names (don’t ask why).
My first idea would have been to just take over ownership of his instances, delete his user and recreate but i actually can’t take ownership of his instances or even create a new instance.

Any ideas?

Still not sure what caused that but the whole cluster is down the flush now.
Breaking up the cluster now in the hope to be able to clean it on a single node… well that does not work either as the onezone commands return but do not do anything.

fsck alone did not solve it as somehow there was a log entry that did throw it back in instantly after at least two nodes were up. Solved it now by first running fsck then truncating logdb backing up the db again and restoring it on all nodes.

Some more details: OpenNebula 5.4.1 running on Arch, 3 node cluster via raft

Now everything is green again