[SOLVED] Error creating disk from template [one.image.allocate]

Hi there, can anyone help me with this error please. I’m trying to import templates from vCenter but whenever i hit this command :

onevcenter templates --vcenter --vuser --vpass

It’s been a week since i’m getting this error and I don’t really know what to do.

Hi, first of all it would be nice to know what version of opennebula are u using.

This error has to do with the stat operation (vcenter driver), you may take a look to your oned.conf and find the same line with the command fail execution.

When you has done this, execute the command stat by yourself (copying command fail line), this will give us a verbose output.

1 Like

Hi Thanks for the answer.
I am using this version of OpenNebula :

You really mean oned.conf ? Because when I try with oned.log This is what I have obtained :

Please can you be more explicit, I don’t really understand what you mean by :

Thanks for answering me.

Sorry i meant oned.log.

As you can see i think that you’re having problem with datastore monitoring.

Try this and show me the output:

$ onedatastore list

1 Like

So I’ve tried the command, this is the output :

Ok i think that your problem is related to the spaces speaking about datastores names(whitespace are not allowed in 5.4.0)

You have two options:

  • upgrade to ONE 5.4.1, we have fixed this issue.
  • Change the name of the datastore in your vcenter and import the datastore again.

I encourage you to use the first option but, if u think that you can manage all the refs without deleting anything you are OK.

Ok i’m trying to update to ONE 5.4.1.
I’ll show the results after that.

So I’ve upgraded to one 5.4.1 but I can’t log to Sunstone anymore :

Ok I can finally log into Sunstone. It was about upgrading the onedb from 5.4.0 to 5.4.1.
But I am still getting the same error.

Hi there !

First of all I will thank you Sergio. You helped me a lot.
So after upgrading to version 5.4.1, I changed the name of the datastore as you suggested and then I imported it with OpenNebula. My error disappeared but another was now displayed:
Not enough space in datastore
While I had about 30 Giga then I saw on a forum this solution:


It actually works ! importation de template à partir du vcenter

The question is : Why OpenNebula is complaining about there is not enough space available in datastore when there is enough space ?

Thanks again.


nice, it seems that you are doing fine.

About your datastore problem, are you sure about this? i guess that opennebula datastore monitoring is working fine, in one of the screen that u posted here it was easy to see that you had space problems (0 % available).

mmm if the datastore poll monitoring says these information it should be true and if not it might be a bug so keep me informed about this if u face the same issue again.

Thanks :slight_smile:

1 Like