[SOLVED] Sunstone broken after upgrade to 5.4.2 (and 5.4.3)


After upgrading to 5.4.2 Sunstone is broken. I get: Sinatra doesn’t know this ditty. (see screenshot). Any ideas how to solve this?

How you upgrade to 5.4.2/5.4.3? Did you build own packages?

It’s a gentoo system. Compiled from source. You made packages for CentOS right? No such problems there?

thanks and cheers

You right, I use CentOS without problems

Debugged a litte bit further. A lot was missing:


I can’t find those files in https://github.com/OpenNebula/one/archive/release-5.4.3.tar.gz. Where do you get those files from?

thanks and cheers

Please @Thomas_Stein make sure you follow these steps:

I managed to solved same problem following the guide. :wink:

Ah, i see. Official builds include those files already i guess.

thanks and cheers

Thank you!
Please inform us if this fixed your problem to mark the issue as solved.

same problem using spec file provided by upstream. Does it mean the spec file for building RPM is incomplete ?

Hi Edouard,

There is an extra step to create the source archive that is used in the spec file that you probably miss in the building process?

Best Regards,
Anton Todorov

Hi @Thomas_Stein, @atodorov_storpool is right. You have to install nodejs, gulp and bower to build assets. I do that and sunstone is working without problems.

You can download my prepared sources

why the extra step is not in the spec ?

It is in package repo

I know. If it was in the spec it should be easier to make package. Here if you grab the source from git, and use the spec, you end up with RPM that install a broken sunstone. That’s all.

EDIT: I forgot to say that the idea is to build Opennebula RPM with mock so it’s not necessary to “pollute” my build machine with npm/bower/etc to modify the sources