[SOLVED] Upgraded to latest opennebula, now can't login to sunstone (Down)

I updated 2 days ago to 5.9.8 and After restarting computer, i’m now unable to login to ANY accounts. In oned.log I see this error when I try to login:
Fri Oct 25 10:37:01 2019 [Z0][AuM][D]: Message received: LOG I 2076 Command execution failed (exit code: 255): /var/lib/one/remotes/auth/server_cipher/authenticate

Fri Oct 25 10:37:01 2019 [Z0][AuM][I]: Command execution failed (exit code: 255): /var/lib/one/remotes/auth/server_cipher/authenticate
Fri Oct 25 10:37:01 2019 [Z0][AuM][D]: Message received: LOG E 2076 bad decrypt

Fri Oct 25 10:37:01 2019 [Z0][AuM][I]: bad decrypt
Fri Oct 25 10:37:01 2019 [Z0][AuM][D]: Message received: AUTHENTICATE FAILURE 2076 bad decrypt

I’ve tried every solution in every article i can find:
#1: Oneuser passwd 0 NEWSPASS, and changed .one/one_auth
#2: Went into mySQL and changed password using SHA1 hash of same password
#3: Made sure that all the *_auth files have the correct password for serveradmin and that the password hash of that password matches what’s in mysql

Nothing works.

One thing I did notice, Is I the oneadmin account, and then I have Windows AD domain controllers that I do LDAP lookups for the other user. None of them can login either, either using the actual AD password, or the password that it has stored for them in MySQL. If I try the oneadmin account with an incorrect password, I get the “incorrect name or username” error in sunstone. But if I try the same user with the correct password, I get a different error “OpenNebula is not running or there was a server exception. Please check the server logs.” The closest thing i’ve found is that someone with same issue said it was incorrect permissions with the authenticate executable, but they didn’t post the correct permissions.

Next attempt will be to remove and re-install without losing all my settings in mysql.

It looks like you’ve missed the note in the blog post?

… Also, note that being a beta, there is no migration path from the previous stable version (5.8.5) nor a migration path to the final stable version (5.10.0).

OpenNebula 5.9.80 is a beta release for testing purposes only.

Hope this helps.

Best Regards,
Anton Todorov

so that does help in one instance that I can stop trying to get it to work. The only reason I tried to upgrade was the prompt in the GUI said “New version available” Which led me to believe there was a “new version availale” and not “a beta version that should only be used for testing” Is there anything I can do to save some of my configuration data? Looks like I have to wipe and reload, are the databases a complete loss?

1 Like

OK, got it back to the older version. I wish the interface wasn’t prompting me to update to an unsupported version, although i’m apparently the only one that fell for it.

1 Like

Hello @michael.blanchard

That issue has been fixed, you can see the status here.

1 Like

Thank you!