Sunstone page failes on a RunTimeError from the first time

I’ve finished installing opennebula, and I tried to open the sunstone web page on but it never opens. It shows application error.
When I checked the sunstine.error :

`== Sinatra has ended his set (crowd applauds)
 /usr/lib/ruby/vendor_ruby/eventmachine.rb:526:in `start_tcp_server': no acceptor (port is in      use or requires root privileges) (RuntimeError)
from /usr/lib/ruby/vendor_ruby/eventmachine.rb:526:in `start_server'
from /usr/lib/ruby/vendor_ruby/thin/backends/tcp_server.rb:16:in `connect'
from /usr/lib/ruby/vendor_ruby/thin/backends/base.rb:63:in `block in start'
from /usr/lib/ruby/vendor_ruby/eventmachine.rb:187:in `run_machine'
from /usr/lib/ruby/vendor_ruby/eventmachine.rb:187:in `run'
from /usr/lib/ruby/vendor_ruby/thin/backends/base.rb:73:in `start'
from /usr/lib/ruby/vendor_ruby/thin/server.rb:162:in `start'
from /usr/lib/ruby/vendor_ruby/rack/handler/thin.rb:19:in `run'
from /usr/lib/ruby/vendor_ruby/sinatra/base.rb:1506:in `start_server'
from /usr/lib/ruby/vendor_ruby/sinatra/base.rb:1444:in `run!
from /usr/lib/one/sunstone/sunstone-server.rb:627:in `<main>'`

I also checked if any other app using same port but found nothing but:

$ sudo netstat -anp | grep ruby
[sudo] password for aly: 
tcp        0      0  *               LISTEN      6768/ruby           
tcp        0      0*               LISTEN      1756/ruby```


~$sudo lsof -i -P -n | grep LISTEN
rpcbind    717            root    8u  IPv4  20116      0t0  TCP *:111 (LISTEN)
rpcbind    717            root   11u  IPv6  20119      0t0  TCP *:111 (LISTEN)
systemd-r  948 systemd-resolve   13u  IPv4  21759      0t0  TCP (LISTEN)
rpc.mount 1427            root    9u  IPv4  26040      0t0  TCP *:43687 (LISTEN)
rpc.mount 1427            root   11u  IPv6  26048      0t0  TCP *:34571 (LISTEN)
rpc.mount 1427            root   13u  IPv4  26054      0t0  TCP *:50573 (LISTEN)
rpc.mount 1427            root   15u  IPv6  26061      0t0  TCP *:60797 (LISTEN)
rpc.mount 1427            root   17u  IPv4  26067      0t0  TCP *:55147 (LISTEN)
rpc.mount 1427            root   19u  IPv6  26073      0t0  TCP *:50317 (LISTEN)
mysqld    1513           mysql   20u  IPv6  29109      0t0  TCP *:3306 (LISTEN)
python    1536        oneadmin    0u  IPv4  29104      0t0  TCP *:29876 (LISTEN)
ruby      1756        oneadmin   10u  IPv4  33557      0t0  TCP (LISTEN)
sshd      1789            root    3u  IPv4  32707      0t0  TCP *:22 (LISTEN)
sshd      1789            root    4u  IPv6  32723      0t0  TCP *:22 (LISTEN)
cupsd     5884            root    6u  IPv6  66075      0t0  TCP [::1]:631 (LISTEN)
cupsd     5884            root    7u  IPv4  66076      0t0  TCP (LISTEN)
ruby      6768        oneadmin   10u  IPv4  87176      0t0  TCP *:9869 (LISTEN)

I guess I knew where the problem is, but I don’t know how to solve it.


Most likely an issue with an already running sunstone process. Reboot the server, make sure there are no ruby processes running, and try again.

Hi @tinova,
I did reboot the PC but nothing changed.
should I kill process on
I killed it and then I checked site but nothing happened even when I tried restarting the service and rebooting PC after, but results are also the same.

5030 is onegate’s port.

the error message you are getting is due to the port being used.

can you confirm that after restart the following comes empty? “sudo netstat -anp | grep ruby”. Also, that after seeing an empty list, you get the same failure starting sunstone?

When I did restart, and tried this command, more ports where in use with ruby.
but unfortunately I re-installed the opennnebula and I am stuck with another issue.
The opennebula service fails to start