Unable to add repo on CENTOS 7 or 8

tried to add community repo to both centos 7 and 8.
on both of them a was not able.
i used this guide http://docs.opennebula.io/5.12/deployment/opennebula_installation/repositories.html#repositories

p.s ubuntu 18 repo worked fine.

centos 7 error when i run yum makecache fast

Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile

One of the configured repositories failed (Unknown),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=<repoid> ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable <repoid>
    or
        subscription-manager repos --disable=<repoid>

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot retrieve metalink for repository: epel/x86_64. Please verify its path and try again

############################################################################

when i tried on centos 8 i get this error

OpenNebula Community Edition 0.0 B/s | 0 B 00:00
Errors during downloading metadata for repository ‘opennebula’:

Hello

Please remove the opennebula repo
/etc/yum.repos.d/opennebula.repo

The error you describe only appears when you mistakenly added the Enterprise Edition repo.

Remove the repo as above and then add the Community Edition below and it will work.

I have added a list of your error when adding the 2 editions.
Hope that helps.

[root@localhost ~]# cat << “EOT” > /etc/yum.repos.d/opennebula.repo

[opennebula]
name=OpenNebula Enterprise Edition
baseurl=https://@enterprise.opennebula.io/repo/5.12/CentOS/7/$basearch
enabled=1
gpgkey=https://downloads.opennebula.io/repo/repo.key
gpgcheck=1
repo_gpgcheck=1
EOT
[root@localhost ~]# yum makecache fast
Failed to set locale, defaulting to C
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • base: centos.mirror.ate.info
  • extras: mirroir.wptheme.fr
  • updates: mirroir.wptheme.fr
    base | 3.6 kB 00:00:00
    extras | 2.9 kB 00:00:00
    https://@enterprise.opennebula.io/repo/5.12/CentOS/7/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 401 - Unauthorized
    Trying other mirror.

One of the configured repositories failed (OpenNebula Enterprise Edition),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=opennebula ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable opennebula
    or
        subscription-manager repos --disable=opennebula

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=opennebula.skip_if_unavailable=true

failure: repodata/repomd.xml from opennebula: [Errno 256] No more mirrors to try.
https://@enterprise.opennebula.io/repo/5.12/CentOS/7/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 401 - Unauthorized
[root@localhost ~]# cd /etc/yum.repos.d
[root@localhost yum.repos.d]# ls
CentOS-Base.repo CentOS-Debuginfo.repo CentOS-Sources.repo CentOS-fasttrack.repo opennebula.repo
CentOS-CR.repo CentOS-Media.repo CentOS-Vault.repo CentOS-x86_64-kernel.repo
[root@localhost yum.repos.d]# rm opennebula.repo
rm: remove regular file ‘opennebula.repo’? y
[root@localhost yum.repos.d]# cat << “EOT” > /etc/yum.repos.d/opennebula.repo

[opennebula]
name=OpenNebula Community Edition
baseurl=https://downloads.opennebula.io/repo/5.12/CentOS/7/$basearch
enabled=1
gpgkey=https://downloads.opennebula.io/repo/repo.key
gpgcheck=1
repo_gpgcheck=1
EOT
[root@localhost yum.repos.d]# yum makecache fast
Failed to set locale, defaulting to C
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

1 Like

SOLVED!
server is a vm and had issues with date and time.
i installed vmware tools sync date and time and repo start working!

Thank you for updating everyone. Glad you got it resolved!!!