Updated vonecloud to, now can't login

I followed directions to upgrade, stopped all services and updated opennebula and rebooted to make sure everything is cleared out. After the reboot, I get the spinning dots and some text of “Opennebula” after logging in. I’ve tried and uninstall and re-installed, i’ve copied back all the original config files (.rpmsave files) and i’ve re-enabled all the opennebula services that were disabled after the update. I’ve also tried onedb fsck and that fixed some errors, but didn’t fix login. I do see this error in httpd.log: AH00037: Symbolic link not allowed or link target not accessible: /usr/lib/one/sunstone/public/dist/main.js, referer: https://lab.url

Hello @michael.blanchard

If you are running Sunsone behind some HTTP server, please follow this guide to configure everything. It seems that you haven’t set the option FollowSymLinks.


I tried that, it wasn’t the fix. I didn’t keep the link, but somehow all of the permissions on the web server directory were messed up and I had to reset them based on an old copy of opennebula I had laying around.