[SOLVED] [vOneCloud] Appliance update to OpenNebula | Control Panel Error

Hello, I am new to this community but I’m using OpenNebula packed with vOneCloud Appliance since 3 years already for the need of my non profit organization.

I am creating this post in the hope to find an answer regardings my problem, because official documentation of vOneCloud or OpenNebula do not provide me any details about it.

I’ve recently get an error with my OpenNebula environment which leds me to reinstall it, so I’ve decided to jump to the latest version compiled by vOneCloud with a single OVA appliance. I have now an OpenNebula environment.

The problem is that I can’t access anymore to the vOneCloud control panel normally available at port 8000/TCP, in order for me to setup an Active Directory connection for example.

In the last version, there was a little button on left side in order to gain access to the appliance management, but it has now disapeared, and when I’m trying to access directly to the console, I get an HTTP connection refused error.

I’ve checked socket state on the appliance via SSH console, and I can confirm that there is no port 8000 opened :

[root@cloud1-srv1 ~]# ss -nutlp
Netid   State    Recv-Q   Send-Q     Local Address:Port      Peer Address:Port                                                                                                                                                                                                 
udp     UNCONN   0        0      *                                                                                                                                                                                                     users:(("chronyd",pid=799,fd=6))
udp     UNCONN   0        0       *                                                                                                                                                                                                     users:(("onemonitord",pid=1404,fd=45))
udp     UNCONN   0        0                  [::1]:323               [::]:*                                                                                                                                                                                                     users:(("chronyd",pid=799,fd=7))
tcp     LISTEN   0        15      *                                                                                                                                                                                                     users:(("oned",pid=1067,fd=46))
tcp     LISTEN   0        100   *                                                                                                                                                                                                     users:(("ruby",pid=1486,fd=18))
tcp     LISTEN   0        80    *                                                                                                                                                                                                     users:(("mysqld",pid=972,fd=44))
tcp     LISTEN   0        128  *                                                                                                                                                                                                     users:(("memcached",pid=845,fd=27))
tcp     LISTEN   0        128       *                                                                                                                                                                                                     users:(("httpd",pid=2455,fd=3),("httpd",pid=1811,fd=3),("httpd",pid=1810,fd=3),                                                                                                                                                                                               ("httpd",pid=1802,fd=3),("httpd",pid=1473,fd=3))
tcp     LISTEN   0        128    *                                                                                                                                                                                                     users:(("ruby",pid=2542,fd=10))
tcp     LISTEN   0        100    *                                                                                                                                                                                                     users:(("python",pid=1230,fd=0))
tcp     LISTEN   0        100   *                                                                                                                                                                                                     users:(("one_hm.rb",pid=1274,fd=39))
tcp     LISTEN   0        100   *                                                                                                                                                                                                     users:(("one_hm.rb",pid=1274,fd=41))
tcp     LISTEN   0        128       *                                                                                                                                                                                                     users:(("sshd",pid=883,fd=4))
tcp     LISTEN   0        8       *                                                                                                                                                                                                     users:(("onemonitord",pid=1404,fd=48))
tcp     LISTEN   0        128                [::1]:11211             [::]:*                                                                                                                                                                                                     users:(("memcached",pid=845,fd=28))
tcp     LISTEN   0        128                 [::]:22                [::]:*                                                                                                                                                                                                     users:(("sshd",pid=883,fd=6))

So the big question is : did the new version disabled the vOneCloud Web Panel for non subscribed user ?
Anyway, I can’t afford 3,000€ since it’s offlimit for my organization’s budget, so I really hope to find a technical issue about it.

Thanks for the reading.

Best Regards,
Valentin BR.

to my knowledge, control panel no longer exists in the latest appliance

Hello @Liorme , and thanks for your feedback.

Indeed I’ve discovered that the control panel no longer exist.

Anyway, I’ve managed to configure my Active Directory authentification in the standard way via OpenNebula conf files directly by SSH.

This is what happens when we rely too much on GUI tools :grin:

We can consider this topic as solved, thanks everyone for your attention, and have a good day.

Best Regards,
Valentin BR.