Uploading fails half way

Please, describe the problem here and provide additional information below (if applicable) …
When I’m trying to upload a big size ISO file through the sunstone website , it stops half way . I can find a lot of chunk errors of 401 , it almost seems like the user is getting logged out and the server does not authenticate the request anymore afterwords. I tried extending the session_expire_timeout on the sunstone-server.conf along with a few more configuration but with no luck .

I also made sure that it’s not permission problem because I did manage to upload a smaller file size of 600mb . Additionally I made sure to restart both the server and the “opennebula opennebula-sunstone” service . I’m running Ubuntu for the server .
Stuff I checked : Allocated size , Permission , Configuration , service restart , log errors or warnings (nothing is logged in unless I forcefully stop the uploading proccess)

Versions of the related components and OS (frontend, hypervisors, VMs):
OS: Ubuntu 22.04 -updated latest .
Users: Personal user, oneadmin
Groups: oneadmin
Disk allocated free : 60GB .
Permission : var/tmp (managed to upload small file)

Steps to reproduce:

  1. Install Ubuntu 22.04 latest
  2. apt update
  3. follow the original OpenNebula Document for Ubuntu installation.
  4. login into sunstone and try uploading an Windows ISO file to image - disk readonly
  5. open inspect on the browser console or tail -f sunstone-log .
    Current results:

401 Unauthorized - HTTP

Expected results:
200 - HTTP and register the ISO for use.

Hello @dupetion!

So I recently actually ran into this issue myself as well when testing some image uploads and I noticed two things (tested on FireEdge Sunstone).

  1. The default size upload limit was set to 20Kb.
  2. The global API timeout was set to a static 45 seconds.

This means that for any request taking longer than 45 seconds, the server would kill the connection, assuming it had timed out or gotten stuck. Which presented itself as a problem in cases where an image upload would take longer than 45 seconds.

We’ve since changed the default upload limit to 10Gb and also made the global API timeout configurable.

Best regards,

Thank you for the answer and it make sense that this could be the problem. I did try to change the ms on any place that I saw that was making sense and of course tried to restart the service and the system itself even to take effect(I know it does not matter but I got frustrated at this poinit) .

Do you mind telling me where have you changed or where do you change the global API timeout configuration ? or is it something that is already updated on the latest OpenNebula Update?

Also the links you added do not work <3 , only the 10GB which I already found ^.^

Edit : Ohhh you made the global API timeout configurable , I was reading it wrong xD . . sorry … . I will try looking for it and see if It fixes the problem . Ill keep you posted <3 and still thanks .

Here is a link to api timeout in public repository

It hasn’t been released yet, available only if you build OpenNebula from source code

1 Like

Thank you :heart: , the case can be closed.
It works like a charm , now I’m stuck with configuring the network with the damm bridge xD . Wish me luck . . . so far I can freaking ping the node from the VM and back but can’t exit outside of it .