Users can't see shared template

Using ONE 5.10.1. I have a template that I’ve granted GROUP and OTHER USE permissions:

[oneadmin@hpc-onet-admin one]$ onetemplate show 0
ID             : 0
NAME           : windows10
USER           : oneadmin
GROUP          : oneadmin

OWNER          : um-
GROUP          : u--
OTHER          : u--

In the template section I also granted USE for the group and other:

  OWNER_U="1" ]

There are virtual networks and an image associated with the template; I also granted USE permissions. I did this in Sunstone and checked on the CLI, and everything looks fine. I didn’t mess around with any ACLs.

I have a regular user (“clouduser”) assigned to a group (“cloudgrp1”), but when they log into Sunstone they can’t see the templates to instantiate. Instead they see a gray box (not the graphical icon I applied to the template), and a trash can that gives them the option to delete the template. If I go to the user pulldown (that has the menu listing Settings, Sign Out, Views, and Groups) and change group from All to my cloudgrp1, they can’t see any templates at all. The user is using the “cloud” view.

I’ve tried various things like cloning the template and changing user and group ownership to clouduser:cloudgrp1 but I’m still not getting results.

I don’t want them to delete the template, they need to instantiate. I’ve tried to follow the User, Groups and Adding Cloud Content in the docs but don’t see what I’m missing. What am doing wrong?

Does anyone have any thoughts on this? It seems to be purely a Sunstone issue, or something I’m doing wrong. As the oneadmin user I can run “onetemplate instantiate --user=clouduser” and the VM is created. So, my clouduser user has access to the template and image and vnet resources associated with it. Clouduser just doesn’t see the user experience I expect in the cloud view when they log in.