VM 1Gbps network interface rx error

I have observed an issue with the KVM VM 1Gbps interface. While adding a 1Gbps interface to the VM generating RX error continuously. Before the upgrade to 1Gpbs, the same VM was running in 100Mbps and working properly.

I would like to request the community to help to resolve the issue.

Hi @mosharaflink,

Could you send the output of onevm show -x <VM_ID>, versions of host and guest OSes, and version of libvirtd you are using.

Cheers.

onevm info attached for your reference. Host OS version is Ubuntu 18.04 and guest OS version is 16.04 and libvirtd (libvirt) version 4.0.0

It seems you forgot to attach the VM info.

onevm-info.txt (2.0 KB)
Thank you for updating me.
Now I am attaching the file for your reference.

You are using the Intel PRO/1000 NIC driver (e1000). Do you have any restriction/requirement to use that network driver (e.g. and old guest OS)? If not, you can try using the para-virtualized network driver (virtio).

We require to use a 1Gpbs network interface for the VM; Interface configuration is managed by OpenNebula; Does there any special configuration for virtio??

When you attach a NIC to a VM, click on advanced options. Scroll to near the bottom to “Hardware model to emulate”. Type “virtio” into that text field.

Hi
Getting following error while trying to virtio interface as your guidence . Please check the screenshot. Also we need 1Gbps interface for VM.

Hmm. I am using a 802.1Q bridge too. Can you post what version of opennebula, OS, and perhaps any customizations you have? I have not seen that error, so hopefully someone else can help.

This is an error which comes from AppArmor denial to some resource. Disable AppArmor or finetune your libvirt policy, various distributions/versions contain various bugs or misbehaviours in their policies.

Finally, I have added the “virtio” interface to the VM and the problem now resolves. One point identified here is the interface speed shows 1Gbps but previously we can add 100mbps. Using virtio option gives the only 1G option for us.