VMXNET3 NIC in vSphere

Whenever I attach a new NIC to a guest, it is always an e1000 which I don’t want. What I want is the vmxnet3 adaptor to be applied. I have amended vmm_exec_vcenter.conf so it it states “NIC=[MODEL=“VirtualVmxnet3”]
” and restarted the system but it makes no difference. Any idea where I’m going wrong…? Thanks

It seems that the driver is not reading the file. Please add the model to the NIC manually and we’ll fill an issue to double check this.


Thanks Rueben. I worked around the issue by changing the e1000 “catch all” to vmxnet3 (as that the only adaptor I want to use currently) in lib/one/ruby/vcenter_driver.rb. This has resolved the issue and now whenever I add a new nic it is a vmxnet3 in vSphere.

File now reads like:
else # If none matches, use VirtualVmxnet3

Issue is opened and we will fix it for OpenNebula 5.2:


I just used the default config file and it is still not setting the correct driver in vsphere.

My /etc/one/vmm_exec/vmm_exec_vcenter.conf is set to:


Changing he vcenter driver default works like a charm though…

The issue didn’t make it in 5.2.0 in the end, we had to retarget it for OpenNebula 5.4, apologies for that.