VNC console in full screen and esc key

When in a full screen VNC console of a running VM and using vim, esc drops you out of full screen.

Is there a way to change the esc key function of a VNC session in the template to some other key?

Versions of the related components and OS (frontend, hypervisors, VMs):
Opennebula Community Edition v6.6.0
Sunstone and Fireedge
OS frontend : Ubuntu 22.04
Hypervisor : KVM
VM’s: Ubuntu 22.04 , RHEL8 etc

Steps to reproduce:
Open a VNC console to a running VM with or without a GUI, click full screen icon, open a file using vim, press esc.
You will be dropped out of fullscreen

 KEYMAP = "en-gb",
 LISTEN = "",
 TYPE = "vnc" ]

Current results:
Dropped out of fullscreen when esc pressed.
Expected results:
Stay in fullscreen when esc pressed.

Thanks for your feedback. This configuration is currently not available, but we believe it is indeed something that should be provided. We’ll add the configuration option (most likely, just for FireEdge) in future OpenNebula versions.

1 Like