Opennebula 6.2.0 @ Character in Chrome VNC session

Hi, I’m currently running opennebula 2.6.0 in my 3 node lab, so far no major issues. I’ve spun up 3 vm’s which I use to run Kubesphere and a vm for an Ubuntu 20.04 minimal desktop with GUIX which I plan to use as my development and automation environment.

The best thing about openebula 2.6.0 Sunstone VNC is that it now allows full screen with a decent screen resolution, its a workable remote environment.

  KEYMAP = "en-gb",
  LISTEN = "",
  PORT = "6446",
  TYPE = "VNC" ]

As you can see above, my local is in the UK and when using VNC in Sunstone there are two problems.

  1. I am not able to enter the @ in a vnc session, all other chars work though. I can however open a Chomium browser and copy and paste the unicode char, I can even use CTL + U0040 to enter an @ sign but both these options are annoying.

Chrome Version 95.0.4638.69 (64-bit) does not allow @ char entry
Firefox Version 94.0 (64-bit) does allow @ char entry sometimes, very intermittent

Unicode @ char

U+0040	@	64	0100	At sign	0033
  1. It would be nice to be able to remap the esc key, in full screen the esc key drops you out of full screen.

Any ideas on any of the above issues?

1 Like

Without making any config changes I’ve intermittently been able to use enter @ but I usually end up with commas auto entered. i.e. @… .
I get the same issues on Chromium and Firefox.