VNC is not working

I have opennebula ver and for now i am trying to set up vnc connection to my vm’s.
When i debug my vnc connection window using chrome web-tools i got the following error:

Mixed Content: The page at servername was loaded over HTTPS, but attempted to connect to the insecure WebSocket endpoint 'ws://servername:2616/fireedge/guacamole?token=some_token. This request has been blocked; this endpoint must be available over WSS.

I have removed token so the error could be readable.

Do i have to enable wss at my system somehow?

Yes. You should alter the Sunstone server configuration file /etc/one/sunstone-server.conf

I have an example of a nginx configuration as a reverse proxy that redirects the traffic to port 443. There is an example of the sunstone server configuration in the comments.

Best Regards,
Anton Todorov