Wild Import Error


We are having an issue importing several VM’s as wilds. We’ve tried everything we found on the forums but without success, such as disabling the PrivateTMP directory in NGINX and still no good.

Basically, what we did was unregistered VM’s from one V-center and then imported them into our new cluster that has Nebula running on-top of it.

All of the VM’s that we are trying to import as wilds are showing the same error. (attached screenshot)

ERROR Error creating disk from template: [one.image.allocate] Cannot parse image SIZE: Error calculating image vcenter://servername-extracted.vmdk size. Reason: “Could not find file.”

Any help on this one?

Hi Michael,

Apparently the driver cannot find one of the disks of the VM. I guess not all the VMs have the sane disk filename. For this particular one disk (servername-extracted.vmdk), can you check what is the path in the vCenter datastore (and if it exists?).

Also useful, please post the output of “onedatastore list -x” using pastebin or a similar service.