Wilds and one-4.14


I searched the docs but i did not find the answer to my questions regarding wilds. The docs say i cannot stop wilds and not migrate them. Okay. I imported a wild VM and tried to connect via vnc but that does not seem to work too. Is that right? This is my wishlist for imported wilds.

  1. Connect via VNC or SPICE
  2. Snapshot the image of an imported wild and create a new VM from it.
  3. Of course migrate the VM.

thanks for your awesome work and cheers

Hi Thomas

Thanks for your feedback, I’ve filled an issue for this, here:

In general, disk related operations are difficult because TM drivers assume
a given disk layout. VNC/SPICE support is probably a low hanging fruit in
your list.


BTW; VNC should be supported.

Hi Ruben.

VNC should be supported? Cool. It did not work on my first tests. I will take a closer look.


Note that it must be already activated in the VM when it was originally

Yeah sure. But how detects opennebula which vnc port is used? Here is the a running wild VM which gets detected by opennebula but vnc is not working.

hn ~ # ps auxw | grep freepbx
qemu      2522  8.7 11.0 8737384 1803056 ?     Sl   11:09   4:27 /usr/bin/qemu-system-x86_64 -name freepbx -S -machine pc-q35-2.4,accel=kvm,usb=off -m 4096 -realtime mlock=off -smp 4,sockets=4,cores=1,threads=1 -uuid fc95a078-be71-4ee3-84b7-0e947d0304d5 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-freepbx/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -boot strict=on -device i82801b11-bridge,id=pci.1,bus=pcie.0,addr=0x1e -device pci-bridge,chassis_nr=2,id=pci.2,bus=pci.1,addr=0x1 -device piix3-usb-uhci,id=usb,bus=pci.2,addr=0x3 -device virtio-serial-pci,id=virtio-serial0,bus=pci.2,addr=0x2 -drive file=/var/lib/libvirt/images/freepbx.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=writethrough,aio=threads -device virtio-blk-pci,scsi=off,bus=pci.2,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,fd=25,id=hostnet0,vhost=on,vhostfd=26 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:26:1a:4b,bus=pci.2,addr=0x1 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/f16x86_64.agent,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=org.qemu.guest_agent.0 -vnc -device cirrus-vga,id=video0,bus=pcie.0,addr=0x1 -device virtio-balloon-pci,id=balloon0,bus=pci.2,addr=0x5 -msg timestamp=on


look around here, it uses dumpxml from virsh


and spice is also supported, my fault :frowning:

On Fri, Oct 16, 2015 at 12:14 PM, Ruben S. Montero <rsmontero@opennebula.org

Thanks Ruben. I’m trying to figure out whats wrong with my setup.


That VM VNC is listening in localhost. That way novnc service is not able to connect. It should listen in all the interfaces, or at least in the interface that matches the host name configured in the frontend.


Uhm. Maybe a firewall issue? Opennebula Frontend (Sunstone) runs behind a NAT and the imported WILD runs on another HardwareNode with a public IP. How can i debug this any further? The logfile are silent regarding vnc connections.

thanks and cheers

By the way. The error message says: “VNC Failed to connect to server (code: 1006)” Let’s see what google says.


Did not read your comment with the advice. I’m trying to adjust that now.

Okay. Setting libvirt to:

<graphics type='vnc' port='-1' autoport='yes' listen=''>

works. But that seems to be a security issue now. What is the best practice for that? Iptables Rules?

thanks and cheers

I have another question. I have 5 VMs running on the hardware node where i’m trying to import wilds from. 4 of them i was able to import. Number 5 is not showing on the “Wilds” TAB in Sunstone. What could be the reason for this? All 5 VMs are more or less the same KVM Machines.

thanks and cheers