5.8 beta 2 upgrade?


I’m new to OpenNebula and I’ve been assessing 5.8 beta 1 (5.7.80) on Ubuntu. However, today I ran an apt upgrade which picked up the beta 2 (5.7.85). I understand that being a beta, an upgrade is probably not officially supported, but it seems that the database version between beta 1 and beta 2 got rolled back from 5.7.80 to 5.6.0. As a result, beta 2 refuses to start on a beta 1 database, and running a onedb upgrade makes no difference.

Is this by design, and I should start fresh/roll back? Or is a fix likely to be coming?


Hi @balmond

Thanks for the feedback!

Yes the database version for the federated tables was wrongly incremented in the beta1. So the right version (and the one 5.8 Final will be shipped with) is 5.6. You can update this value directly in the database, The final table should look something like:

MariaDB [opennebula]> select * from db_versioning;
| oid | version | timestamp  | comment                            |
|   0 | 5.6.0   | 1549450991 | OpenNebula 5.7.85 daemon bootstrap |
1 row in set (0.01 sec)

Thanks again for giving beta2 a try! :smiley:

Thank you, that worked! I’m probably just making issues for myself by not just starting with a clean install, but I didn’t want to lose what I had :grinning:

Hopefully I’m not missing too many database changes, but I did have errors creating VMs until I ran:

ALTER TABLE vm_pool ADD search_token MEDIUMTEXT;

Apart from that, all seems fine :grinning: