AppMarket - can't create appliance or new user

Hello dears,

I’m trying to deploy AppMarket on a standalone server.
I realize that AppMarket is deprecated in favor of HTTP Marketplace, but I don’t have any other chance to provide access to appliances for different unrelated (unfederated?) OpenNebula installations.
Let’s say I need a kind of public marketplace within a company or a group of companies.
Now I have installed appmarket on separate server, no errors during installation, service is up and running. And I can access appmarket URL through a web browser and sign in.
But I can’t either create a new user or new appliance. All the attempts end up with a message:

  "message": "already exists"

I tried using cli and appmarket web interface - both return the same message.
In web browser inspector I saw that in attempt to POST new appliance or user appmarket server responds with HTTP 400 error, and I don’t understand why is that so.

So, the bottom line.
Any ideas why the error shows up?
And would appmarket work as a standalone service?

Will appreciate all assumptions.

Thanks a lot!

1 Like

Hi, looking into source code I can see that error already exists will report about any mongodb error.

This error was in my mongodb log:

command market.$cmd command: unrecognized numYields:0 ok:0 errMsg:"BSON field 'insert.w' is an unknown field." errName:Location40415 errCode:40415 reslen:146 locks:{} protocol:op_query 0ms

The problem solved after downgrading to mongo v2.6.12