Appmarket installation problem


I deployed opennebula on CENTOS 7 and it is working fine. Thanks for nice documentation for newbie to starting it.

I am trying to install appmarket and I followed github page for that. I setup mongodb and install appmarket rpm on centos 7. Also installed suggested gem bundle and all happened good.

but when i tried to start /etc/init.d/opennebula-appmarket service, I got below errors in log file.

# cat /var/log/one/appmarket-server.error 
/usr/lib/one/ruby/oneapps/market/init.rb:34:in `<module:AppMarket>': uninitialized constant Mongo::Connection (NameError)
	from /usr/lib/one/ruby/oneapps/market/init.rb:22:in `<top (required)>'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /usr/lib/one/ruby/oneapps/market/models.rb:17:in `<top (required)>'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
	from /usr/lib/one/ruby/oneapps/market/controllers/appmarket-server.rb:42:in `<main>'

I run standard mongodb configuration where it is running on and according to that I set same for DB settings in appmarket.conf file. I haven’t made any other changes in appmarket.conf file or in mongodb.conf file.

selinux and firewall is diabled.

Can you please suggest me what would be missing here which generating error?


Hi Ben,

It looks like there is a problem with the mongo gem 2.x, could you try removing this gem and installing a previous version (1.x)


Hi Daniel,

Thanks for your response. yes it is working now.