Receiving message "User not authorized" when trying to create a new appliace on AppMarket


We have installed a testbed for OpenNebula which it has a similar configuration than the one that we have on production. Now, I am trying to create a new appliance on the AppMarket from the Sunstone UI but I received the following error: “User not authorized”.

First of all, I have to mention that we have decided to separate the OpenNebula, Sunstone and APP-Market in three different nodes. Also, we are using our own market place.

I don’t understand why I am receiving this error when I see the users for the AppMarket created correctly:

[root@test-appmarket4 system]# appmarket-user list -u  -p 
                   ID                 NAME     ROLE     STATUS
 55cdb73ac5cda60492000001            appmarket    admin    enabled
 55cdd257c5cda611c3000001               worker   worker    enabled

Probably, Im missing something but in any case, any help is welcome :smile:

Thanks in advance,

Maybe a clue about the issue, I connected to the appmarket server through the web browser with the admin user and I was able to create a new appliance but I am not seeing the new appliance created from the sunstone UI, so I guess I am missing some configuration on the sunstone UI.

Also, I tried to connect to the appmarket server through the web browser with the worker user but I received the following error:

The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept cookies.

I don’t know if this is normal or not but I have seen we have the same error on production when trying to connect to the appmarket server through the web browswer with the worker user.

Thanks in advance,

It was my fault, I did not pay attention to the following paragraph when reading the documentation, :

Or you can define a different account for each user adding the APPMARKET_USER and APPMARKET_PASSWORD 
in the template of the user. This can be achieved from the settings dialog of Sunstone or using the oneuser command  
from the CLI.

So I just have added these variables to the template of the user and everything is working now.

Sorry for the noise :smile: