Ceph HCI Ansible version issue

Hi all,

I’ve setup a new cluster with OpenNebula 6.8.0 on Ubuntu 22.04 and all went smoothly.

The next step was to setup Ceph HCI to use the SSDs present on each of the 3 nodes as datastore for the cluster.

I’ve followed this document to implement Ceph HCI:
https://docs.opennebula.io/6.8/provision_clusters/hci_clusters/onprem_cluster_ceph.html

I did notice that the document mentioned specifically Ubuntu 20.04 instead of 22.04 as supported by the front-end but thought it might be compatible anyway and maybe the docs needed updating.

The end result is that during the script created 3 new hosts instead of using the hosts already configured and then it stopped with the following error:

ERROR: Unsupported Ansible ver. 2.9.27, must be >= 2.12 and < 2.13

Ansible-core 2.9.27 is the version available with Ubuntu 22.04 while the ppa provides version 2.16.7.

Is there any specific showstoppers in using ansible-core 2.16.7?

I could reinstall everything using Ubuntu 20.04 but it would be great to be able to use 22.04 as it’s the latest version supported by the front-end and I’d be happy to use my cluster as a testbed for a new version of the HCI install process.

Thanks

Paolo